Manuals
Manuals




This translation is community contributed and may not be up to date. We only maintain the English version of the documentation. Read this manual in English

Düzenleyiciye genel bakış

Düzenleyici, oyun projenizdeki tüm dosya ve klasörlere göz atmanızı ve bunlar üzerinde verimli bir şekilde işlem yapmanızı sağlar. Bir dosyayı düzenlemeye başladığınızda uygun düzenleyici açılır ve dosyayla ilgili tüm bilgiler ayrı görünümlerde gösterilir.

Düzenleyiciyi başlatma

Defold düzenleyicisini çalıştırdığınızda proje seçme ve oluşturma ekranı açılır. Yapmak istediğiniz işlemi tıklayarak seçin:

MY PROJECTS
Yakın zamanda açtığınız projeler, onlara hızlıca erişebilmeniz için burada bulunur. Bu, başlangıç ekranının varsayılan görünümüdür.

Daha önce hiç proje açmadıysanız (veya tümünü kaldırdıysanız) iki düğme gösterilir. Sistem dosya tarayıcısıyla bir proje bulup açmak için Open From Disk… düğmesine tıklayabilir veya Create New Project düğmesine tıklayarak TEMPLATES sekmesine geçebilirsiniz.

Projelerim

Daha önce proje açtıysanız aşağıdaki resimdeki gibi projelerinizin listesi gösterilir:

Projelerim

TEMPLATES
Belirli platformlar için veya belirli eklentileri kullanarak yeni bir Defold projesine hızlıca başlamanız amacıyla hazırlanmış boş ya da neredeyse boş temel projeleri içerir.
TUTORIALS
Bir öğreticiyi izlemek istiyorsanız öğrenebileceğiniz, oynayabileceğiniz ve değiştirebileceğiniz, adım adım yönlendiren öğreticiler içeren projeler sunar.
SAMPLES
Belirli kullanım senaryolarını göstermek için hazırlanmış projeler içerir.

Yeni proje

Yeni bir proje oluşturduğunuzda proje yerel sürücünüzde saklanır ve yaptığınız tüm değişiklikler yerel olarak kaydedilir.

Farklı seçenekler hakkında daha fazla bilgiyi Proje kurulumu kılavuzunda bulabilirsiniz.

Düzenleyici dili

Başlangıç ekranının sol alt köşesinde dil seçimini görebilirsiniz. Mevcut yerelleştirmelerden birini seçin. Bu ayara düzenleyicide File ▸ Preferences ▸ General ▸ Editor Language yolundan da erişebilirsiniz.

Diller

Düzenleyici bölmeleri

Defold düzenleyicisi, belirli bilgileri gösteren bölmelerden veya görünümlerden oluşur.

Düzenleyici 2

1. Assets bölmesi

Projenizdeki tüm dosya ve klasörleri, diskinizdeki yapıyla aynı olan bir ağaç yapısında listeler. Listede gezinmek için tıklayın ve kaydırın. Dosyalarla ilgili tüm işlemleri bu görünümde yapabilirsiniz:

  • Herhangi bir dosya veya klasörü seçmek için sol tıklayın; ⇧ Shift tuşunu basılı tutarak seçimi genişletebilir veya Ctrl/⌘ Cmd tuşunu basılı tutarak tıkladığınız öğeyi seçebilir ya da seçimden çıkarabilirsiniz.
  • Bir dosyayı, dosya türüne özgü düzenleyicide açmak için dosyaya çift tıklayın.
  • Diskinizdeki başka konumlardan projeye dosya eklemek veya dosya ve klasörleri proje içinde yeni konumlara taşımak için sürükleyip bırakın.
  • Yeni dosya veya klasör oluşturabileceğiniz, yeniden adlandırma, silme, dosya bağımlılıklarını izleme ve başka işlemler yapabileceğiniz bağlam menüsünü açmak için sağ tıklayın.

Assets bölmesinden silinen dosya ve klasörler, platform destekliyorsa sistemin Trash veya Recycle Bin klasörüne taşınır. Bir öğeyi çöp kutusuna taşıma desteklenmiyorsa veya başarısız olursa düzenleyici öğeyi kalıcı olarak siler.

2. Scene Editor bölmesi

Bir koleksiyon (collection), oyun nesnesi (game object) veya görsel bileşen (component) dosyasına çift tıkladığınızda, sahne oluşturmak ve düzenlemek için kullanılan görsel düzenleyici olan Scene Editor açılır. Betik dosyaları ve görsel olmayan diğer kaynaklar (resource) ise kendilerine özgü düzenleyicilerde açılır.

Scene Editor görünümü

Scene Editor tarafından sunulan temel özelliklerden bazıları:

Daha fazla bilgiyi Sahne düzenleyicisi kılavuzunda bulabilirsiniz.

3. Outline bölmesi

Bu görünüm, düzenlemekte olduğunuz dosyanın içeriğini hiyerarşik bir ağaç yapısında gösterir. Outline, düzenleyici görünümünü yansıtır ve öğeleriniz üzerinde işlem yapmanızı sağlar:

  • Bir öğeyi seçmek için sol tıklayın; ⇧ Shift tuşunu basılı tutarak seçimi genişletebilir veya Ctrl/⌘ Cmd tuşunu basılı tutarak tıkladığınız öğeyi seçebilir ya da seçimden çıkarabilirsiniz.
  • Öğeleri taşımak için sürükleyip bırakın. Üst-alt nesne ilişkisi oluşturmak için bir koleksiyondaki oyun nesnesini başka bir oyun nesnesinin üzerine bırakın.
  • Öğe ekleyebileceğiniz, seçili öğeleri silebileceğiniz ve benzeri işlemler yapabileceğiniz bağlam menüsünü açmak için sağ tıklayın.

Listedeki bir öğenin sağında bulunan küçük 👁 göz simgesine tıklayarak oyun nesnelerinin ve görsel bileşenlerin görünürlüğünü değiştirebilirsiniz.

Outline bölmesi

4. Properties bölmesi

Bu görünüm, seçili öğeyle ilişkili Id, URL, Position, Rotation, Scale gibi özellikleri ve/veya bileşene özgü diğer özellikleri, ayrıca betiklerin özel özelliklerini gösterir.

Sayısal bir özelliğin değerini, yukarı-aşağı okunu sürükleyerek ve fareyi hareket ettirerek de değiştirebilirsiniz.

Properties bölmesi

5. Tools bölmesi

Bu görünümde birkaç sekme bulunur.

Console sekmesi: oyununuz çalışırken motorun ürettiği hata, uyarı ve bilgi çıktılarını veya sizin özellikle yazdırdığınız çıktıları gösterir,

Build Errors: proje derleme sürecindeki hataları gösterir,

Search Results: Keep Results düğmesine tıklarsanız projenin tamamında yaptığınız aramanın (Ctrl/⌘ Cmd + Shift + F) sonuçlarını gösterir

Curve Editor: Parçacık düzenleyicisinde eğrileri düzenlerken kullanılır.

Tools bölmesi, tümleşik hata ayıklayıcıyla etkileşim kurmak için de kullanılır. Daha fazla bilgiyi Hata ayıklama kılavuzunda bulabilirsiniz.

6. Changed Files bölmesi

Projenizde Git kullanılıyorsa bu görünüm, geçerli Git kaydına (commit) (HEAD) kıyasla yerel olarak değiştirilen, eklenen, yeniden adlandırılan veya silinen dosyaları listeler. Uzak bir depoyla eşitlemek için harici bir Git istemcisi veya komut satırını kullanın. Daha fazla bilgiyi Sürüm kontrolü kılavuzunda bulabilirsiniz. Dosyalarla ilgili bazı işlemleri bu görünümde yapabilirsiniz:

  • Bir dosyayı seçmek için sol tıklayın; ⇧ Shift tuşunu basılı tutarak seçimi genişletebilir veya Ctrl/⌘ Cmd tuşunu basılı tutarak tıkladığınız öğeyi seçebilir ya da seçimden çıkarabilirsiniz. Değiştirilmiş tek bir dosya seçiliyse farkları göstermek için Diff düğmesine tıklayabilirsiniz. Seçili tüm dosyalardaki değişiklikleri geri almak için Revert düğmesine tıklayabilirsiniz.
  • Bir dosyanın görünümünü açmak için dosyaya sol tuşla çift tıklayın. Düzenleyici, Assets görünümünde olduğu gibi dosyayı uygun düzenleyicide açar.
  • Fark görünümünü açabileceğiniz, dosyada yapılan tüm değişiklikleri geri alabileceğiniz, dosyayı dosya sisteminde bulabileceğiniz ve başka işlemler yapabileceğiniz açılır menüyü açmak için dosyaya sağ tıklayın.

Menü çubuğu

Düzenleyici görünümünün üst kısmında veya Mac’te sistem çubuğunda, 6 menü içeren menü çubuğunu bulabilirsiniz: File, Edit, View, Project, Debug, Help. Bu menülerin işlevleri kılavuzlarda açıklanacaktır.

Durum çubuğu

Düzenleyicinin alt çubuğunda, durumun gösterildiği dar bir alan bulunur. Örneğin:

  • Yeni bir güncelleme mevcut olduğunda tıklanabilir Update Available düğmesi görünür. Bu kılavuzun aşağıdaki Düzenleyiciyi güncelleme bölümüne bakın.
  • Proje derlenirken veya paketlenirken ilerleme burada gösterilir.

Bölme boyutu ve görünürlüğü

Düzenleyicide bölmelerin boyutunu, yukarıda açıklanan 6 bölme arasındaki sınırları sürükleyerek ayarlayabilirsiniz.

Düzenleyicide bölmelerin görünürlüğünü View menüsündeki seçenekleri veya belirtilen kısayolları kullanarak değiştirebilirsiniz:

  • Toggle Assets Pane (F6), Assets ve Changed Files bölmelerinin görünürlüğünü değiştirir
  • Toggle Changed Files, yalnızca Changed Files bölmesinin görünürlüğünü değiştirir
  • Toggle Tools Pane (F7), Tools bölmesinin görünürlüğünü değiştirir
  • Toggle Properties Pane (F8), Outline ve Properties bölmelerinin görünürlüğünü değiştirir

Bölme görünürlüğü

View menüsünden Grid, Guides veya Camera gibi görünürlükle ilgili diğer ayarları da açıp kapatabilir ya da değiştirebilir, görünümü seçime sığdırabilir (Frame Selection veya F tuşu) ve varsayılan 2B ve 3B görünümler arasında geçiş yapabilirsiniz (Realign Camera veya . tuşu). Bunların çoğuna araç çubuğundan veya kısayollarla da erişilebilir.

Sekmeler

Birden fazla dosya açıksa düzenleyici görünümünün üst kısmında her dosya için ayrı bir sekme gösterilir. Aynı bölmedeki sekmelerin yerini değiştirebilirsiniz; sekme çubuğundaki konumlarını değiştirmek için sürükleyip bırakın. Ayrıca şunları yapabilirsiniz:

  • Bir bağlam menüsü açmak için sekmeye sağ tıklayın,
  • Tek bir sekmeyi kapatmak için Close (Ctrl/⌘ Cmd + W) seçeneğine tıklayın,
  • Seçili sekme dışındaki tüm sekmeleri kapatmak için Close Others seçeneğine tıklayın,
  • Etkin bölmedeki tüm sekmeleri kapatmak için Close All (Ctrl/⌘ Cmd + Shift+W) seçeneğine tıklayın,
  • Varsayılan düzenleyici dışında bir düzenleyici veya File ▸ Preferences ▸ Code ▸ Custom Editor altında ayarlanmış ilişkili harici aracı kullanmak için ➝| Open As seçeneğini seçin. Daha fazla bilgiyi Tercihler kılavuzunda bulabilirsiniz.

Sekmeler

Yan yana düzenleme

2 düzenleyici görünümünü yan yana açabilirsiniz.

  • Taşımak istediğiniz düzenleyicinin sekmesine sağ tıklayın ve Move to Other Tab Pane seçeneğini seçin.

2 bölme

Sekme menüsündeki Swap with Other Tab Pane seçeneğiyle bir sekmeyi bölmeler arasında taşıyabilir veya Join Tab Panes seçeneğiyle bölmeleri tek bir bölmede birleştirebilirsiniz.

Yeni proje dosyaları oluşturma

Yeni kaynak dosyaları oluşturmak için File ▸ New… seçeneğini seçip menüden dosya türünü belirleyin veya bağlam menüsünü kullanın:

Assets tarayıcısında hedef konuma sağ tıklayın, ardından New… ▸ [file type] seçeneğini seçin:

Dosya oluşturma

Yeni dosya için Name alanına uygun bir ad yazın ve gerekirse Location alanındaki konumu değiştirin. Dosya türü uzantısı dahil tam dosya adı, iletişim kutusundaki Preview alanında gösterilir:

Oluşturulacak dosyanın adı

Şablonlar

Her proje için özel şablonlar belirleyebilirsiniz. Bunun için projenin kök dizininde templates adlı yeni bir klasör oluşturun ve /templates/default.gui veya /templates/default.script gibi istediğiniz uzantılara sahip, default.* biçiminde adlandırılmış yeni dosyalar ekleyin. Ayrıca bu dosyalarda {{NAME}} belirteci kullanılırsa yerine dosya oluşturma penceresinde belirtilen dosya adı konur.

Belirli bir dosya türü için şablon varsa bu türde yeni bir dosya oluşturulduğunda dosyanın başlangıç içeriği templates klasöründeki dosyadan alınır.

Şablonlar

Dosyaları projenize içe aktarma

Projenize varlık (asset) dosyaları (görüntüler, sesler, modeller vb.) eklemek için dosyaları Assets tarayıcısında uygun konuma sürükleyip bırakmanız yeterlidir. Böylece proje dosya yapısında seçilen konumda dosyaların kopyaları oluşturulur. Daha fazla bilgiyi varlıkları içe aktarma kılavuzumuzda bulabilirsiniz.

Dosyaları içe aktarma

Düzenleyiciyi güncelleme

Düzenleyici, internete bağlıyken güncellemeleri otomatik olarak denetler. Bir güncelleme algılandığında proje seçme ekranının sol alt köşesinde veya düzenleyici penceresinin sağ alt köşesinde, tıklanabilir mavi Update Available bağlantısı gösterilir.

Proje seçim ekranından güncelleme Düzenleyiciden güncelleme

İndirmek ve güncellemek için tıklanabilir Update Available bağlantısına basın. Bilgi içeren bir onay penceresi açılır; devam etmek için Download Update düğmesine tıklayın.

Düzenleyiciyi güncelleme penceresi

İndirme ilerlemesini alttaki durum çubuğunda görebilirsiniz:

İndirme ilerlemesi

Güncelleme indirildikten sonra mavi bağlantı Restart to Update olarak değişir. Yeniden başlatmak ve güncellenmiş düzenleyiciyi açmak için bu bağlantıya tıklayın.

Güncellemek için yeniden başlatma

Tercihler

Düzenleyicinin ayarlarını Preferences penceresinde değiştirebilirsiniz. Bu pencereyi açmak için File ▸ Preferences… seçeneğine tıklayın veya Ctrl/⌘ Cmd + , kısayolunu kullanın

Daha fazla ayrıntıyı Tercihler kılavuzunda bulabilirsiniz

Preferences penceresi

Düzenleyici günlükleri

Düzenleyicide bir sorunla karşılaşıp bunu bildirmeniz gerektiğinde (Help ▸ Report Issue), düzenleyicinin günlük dosyalarını da sağlamanız iyi olur. Günlüklerin konumunu sisteminizin dosya tarayıcısında açmak için Help ▸ Show Logs seçeneğine tıklayın.

Daha fazla bilgiyi Yardım alma kılavuzunda bulabilirsiniz.

Show Logs seçeneği

Düzenleyici günlük dosyalarını şu konumlarda bulabilirsiniz:

  • Windows: C:\Users\ **Your Username** \AppData\Local\Defold
  • macOS: /Users/ **Your Username** /Library/Application Support/ veya ~/Library/Application Support/Defold
  • Linux: $XDG_STATE_HOME/Defold veya ~/.local/state/Defold

Düzenleyici bir terminalden/komut isteminden başlatıldıysa çalışırken de düzenleyici günlüklerine erişebilirsiniz. Düzenleyiciyi başlatmak için şu komutu kullanın:

# Linux:
$ ./path/to/Defold/Defold

# macOS:
$ > ./path/to/Defold.app/Contents/MacOS/Defold

Düzenleyici sunucusu

Düzenleyici bir proje açtığında rastgele bir bağlantı noktasında web sunucusu başlatır. Bu sunucu, diğer uygulamalardan düzenleyiciyle etkileşim kurmak için kullanılabilir. Bağlantı noktası .internal/editor.port dosyasına yazılır.

Sunucu, http://localhost:$(cat .internal/editor.port)/openapi.json adresinde bir OpenAPI belirtimi sunar. Bu, ajanların yürüttüğü iş akışları için yararlı ve temel bir başlangıç noktasıdır.

Ayrıca düzenleyicinin yürütülebilir dosyası, başlatma sırasında bağlantı noktası belirtmenizi sağlayan --port (veya -p) komut satırı seçeneğine sahiptir. Örneğin::

# Windows
.\path\to\Defold\Defold.exe --port 8181

# Linux:
./path/to/Defold/Defold --port 8181

# macOS:
./path/to/Defold/Defold.app/Contents/MacOS/Defold --port 8181

Düzenleyici kurulum üst verileri

Düzenleyici başlatıldığında, başlatıcı ve kurulum yolları hakkındaki bilgileri bilinen bir konuma yazar. Üçüncü taraf IDE tümleştirmeleri ve diğer araçlar bu bilgileri kurulu Defold düzenleyicilerini bulmak için kullanabilir:

İşletim sistemi Konum
macOS ~/Library/Application Support/Defold/installations.json
Linux ${XDG_STATE_HOME:-~/.local/state}/Defold/installations.json
Windows %LOCALAPPDATA%\Defold\installations.json

Dosya, bilinen her kurulum için bir nesne içeren bir JSON dizisi içerir:

[
  {
    "launcherPath": "/Applications/Defold.app/Contents/MacOS/Defold",
    "installPath": "/Applications/Defold.app",
    "lastLaunchedAt": "2026-07-06T12:34:56.789Z"
  }
]

Düzenleyici biçimlendirmesi

Düzenleyicinin görünümü özel biçimlendirmeyle değiştirilebilir. Daha fazla bilgiyi Düzenleyici biçimlendirme kılavuzunda bulabilirsiniz.

Sık sorulan sorular

Q: Düzenleyicinin sistem gereksinimleri nelerdir?

A: Düzenleyici (editor), sistemde kullanılabilir belleğin %75’ine kadarını kullanır. 4 GB RAM bulunan bir bilgisayarda bunun küçük Defold projeleri için yeterli olması beklenir. Orta büyüklükteki veya büyük projeler için 6 GB veya daha fazla RAM kullanılması önerilir.

Q: Defold’un beta sürümleri otomatik olarak güncelleniyor mu?

A: Evet. Defold’un beta düzenleyicisi, kararlı sürümde olduğu gibi başlangıçta güncellemeleri kontrol eder.

Q: Düzenleyiciyi başlatırken neden java.awt.AWTError: Assistive Technology not found hatasını alıyorum?

A: Bu hata, NVDA ekran okuyucusu gibi Java yardımcı teknolojileriyle ilgili sorunlardan kaynaklanır. Muhtemelen kullanıcı klasörünüzde bir .accessibility.properties dosyası vardır. Dosyayı kaldırın ve düzenleyiciyi yeniden başlatmayı deneyin. (Not: Herhangi bir yardımcı teknoloji kullanıyorsanız ve bu dosyanın bulunması gerekiyorsa alternatif çözümleri görüşmek için lütfen info@defold.se adresinden bizimle iletişime geçin).

Bu konu Defold forumunda burada ele alınmıştır.

Q: Düzenleyiciyi başlatırken neden sun.security.validator.ValidatorException: PKIX path building failed hatasını alıyorum?

A: Bu istisna, düzenleyici bir https bağlantısı kurmaya çalıştığında sunucunun sağladığı sertifika zinciri doğrulanamıyorsa ortaya çıkar.

Bu hata hakkında ayrıntılı bilgi için bu bağlantıya bakın.

Q: Belirli işlemleri gerçekleştirirken neden java.lang.OutOfMemoryError: Java heap space hatasını alıyorum?

A: Defold düzenleyicisi Java kullanılarak geliştirilmiştir ve bazı durumlarda Java’nın varsayılan bellek yapılandırması yeterli olmayabilir. Bu durumda düzenleyicinin yapılandırma dosyasını düzenleyerek daha fazla bellek ayırmasını elle yapılandırabilirsiniz. config adlı yapılandırma dosyası, macOS’te Defold.app/Contents/Resources/ klasöründe bulunur. Windows’ta Defold.exe yürütülebilir dosyasının, Linux’ta ise Defold yürütülebilir dosyasının yanında bulunur. config dosyasını açın ve -Xmx6gb seçeneğini vmargs ile başlayan satıra ekleyin. -Xmx6gb eklemek, en büyük öbek (heap) boyutunu 6 gigabayt olarak ayarlar (varsayılan değer genellikle 4Gb’dir). Şuna benzer bir görünüm elde etmelisiniz:

vmargs = -Xmx6gb,-Dfile.encoding=UTF-8,-Djna.nosys=true,-Ddefold.launcherpath=${bootstrap.launcherpath},-Ddefold.resourcespath=${bootstrap.resourcespath},-Ddefold.version=${build.version},-Ddefold.editor.sha1=${build.editor_sha1},-Ddefold.engine.sha1=${build.engine_sha1},-Ddefold.buildtime=${build.time},-Ddefold.channel=${build.channel},-Ddefold.archive.domain=${build.archive_domain},-Djava.net.preferIPv4Stack=true,-Dsun.net.client.defaultConnectTimeout=30000,-Dsun.net.client.defaultReadTimeout=30000,-Djogl.texture.notexrect=true,-Dglass.accessible.force=false,--illegal-access=warn,--add-opens=java.base/java.lang=ALL-UNNAMED,--add-opens=java.desktop/sun.awt=ALL-UNNAMED,--add-opens=java.desktop/sun.java2d.opengl=ALL-UNNAMED,--add-opens=java.xml/com.sun.org.apache.xerces.internal.jaxp=ALL-UNNAMED