Manuals
Manuals




This translation is community contributed and may not be up to date. We only maintain the English version of the documentation. Read this manual in English

エディターの概要

エディターでは、ゲームプロジェクト内のすべてのファイルとフォルダーを効率よく閲覧、操作できます。ファイルを編集すると、そのファイルに適したエディターが開き、関連するすべての情報が個別のビューに表示されます。

エディターの起動

Defold エディターを実行すると、プロジェクトを選択、作成する画面が表示されます。実行したい操作をクリックして選択します。

MY PROJECTS
最近開いたプロジェクトが表示され、すぐにアクセスできます。起動画面の既定のビューです。

これまでにプロジェクトを開いていない場合(またはすべて削除した場合)は、2つのボタンが表示されます。Open From Disk… をクリックすると、システムのファイルブラウザーでプロジェクトを探して開けます。Create New Project ボタンをクリックすると、TEMPLATES タブに切り替わります。

自分のプロジェクト

以前にプロジェクトを開いたことがある場合は、次の画像のようにプロジェクトの一覧が表示されます。

自分のプロジェクト

TEMPLATES
特定のプラットフォーム向け、または特定の拡張を使う新しい Defold プロジェクトをすぐに始められるように作られた、空またはほぼ空の基本的なプロジェクトが用意されています。
TUTORIALS
チュートリアルに沿って進めたい場合に、手順を見ながら学び、遊び、変更できるチュートリアル付きのプロジェクトが用意されています。
SAMPLES
特定の使用例を紹介するためのプロジェクトが用意されています。

新しいプロジェクト

新しいプロジェクトを作成すると、ローカルドライブに保存され、編集内容もすべてローカルに保存されます。

各選択肢について詳しくは、プロジェクトのセットアップマニュアルを参照してください。

エディターの言語

起動画面の左下には言語の選択欄があり、現在利用できる言語から選択できます。エディター内の File ▸ Preferences ▸ General ▸ Editor Language からも選択できます。

言語

エディターのペイン

Defold エディターは、特定の情報を表示する複数のペイン(ビュー)に分かれています。

エディター 2

1. Assets ペイン {#1-assets-pane}

プロジェクトに含まれるすべてのファイルとフォルダーを、ディスク上と同じツリー構造で一覧表示します。クリックやスクロールで一覧を移動できます。このビューでは、ファイルに関するすべての操作を実行できます。

  • 左クリックでファイルやフォルダーを選択します。⇧ Shift を押しながら操作すると選択範囲を広げられ、Ctrl/⌘ Cmd を押しながら操作すると、クリックした項目の選択と選択解除を切り替えられます。
  • ファイルをダブルクリックすると、そのファイル形式専用のエディターで開きます。
  • ドラッグ&ドロップで、ディスク上のほかの場所からプロジェクトにファイルを追加したり、プロジェクト内でファイルやフォルダーを別の場所に移動したりできます。
  • 右クリックコンテキストメニュー を開き、新しいファイルやフォルダーの作成、名前の変更、削除、ファイルの依存関係の確認などを実行できます。

Assets ペインから削除したファイルやフォルダーは、プラットフォームが対応している場合、システムのごみ箱に移動します。ごみ箱への移動に対応していない場合や移動に失敗した場合、エディターはその項目を完全に削除します。

2. シーンエディターペイン

コレクション(collection)、ゲームオブジェクト(game object)、または視覚的なコンポーネント(component)のファイルをダブルクリックすると、シーンの構築と編集に使うビジュアルエディター、Scene Editor(シーンエディター)が開きます。スクリプトファイルや、視覚的な要素を持たないその他のリソースは、それぞれの専用エディターで開きます。

シーンエディター

シーンエディターが提供する主な機能には、次のものがあります。

詳しくは、シーンエディターのマニュアルを参照してください。

3. Outline ペイン {#3-outline-pane}

このビューは、現在編集中のファイルの内容を階層的なツリー構造で表示します。Outline はエディタービューの内容を反映し、項目に対して次の操作を実行できます。

  • 左クリックで項目を選択します。⇧ Shift を押しながら操作すると選択範囲を広げられ、Ctrl/⌘ Cmd を押しながら操作すると、クリックした項目の選択と選択解除を切り替えられます。
  • ドラッグ&ドロップで項目を移動します。コレクション内のゲームオブジェクトを別のゲームオブジェクトにドロップすると、親子関係を作成できます。
  • 右クリックコンテキストメニュー を開き、項目の追加、選択した項目の削除などを実行できます。

一覧の各要素の右側にある小さな 👁 の目のアイコンをクリックすると、ゲームオブジェクトや視覚的なコンポーネントの表示を切り替えられます。

アウトライン

4. Properties ペイン {#4-properties-pane}

このビューは、現在選択されている項目に関連するプロパティを表示します。Id、URL、Position、Rotation、Scale のほか、コンポーネント固有のプロパティや、スクリプトのカスタムプロパティも表示します。

の上下矢印をドラッグしてマウスを動かすと、対応する数値プロパティの値を変更できます。

プロパティ

5. Tools ペイン {#5-tools-pane}

このビューには複数のタブがあります。

Console タブ : ゲームの実行中にエンジンが出力するエラー、警告、情報、および自分で意図的に出力した内容を表示します。

Build Errors : ビルド処理のエラーを表示します。

Search Results : プロジェクト全体を検索(Ctrl/⌘ Cmd + Shift + F)したときに、Keep Results をクリックすると検索結果を表示します。

Curve Editor : パーティクルエディターでカーブを編集するときに使用します。

Tools ペインは、統合デバッガーの操作にも使用します。詳しくは、デバッグマニュアルを参照してください。

6. Changed Files ペイン {#6-changed-files-pane}

プロジェクトで Git を使用している場合、このビューは現在のコミット(HEAD)と比較して、ローカルで変更、追加、名前の変更、削除が行われたファイルを一覧表示します。リモートリポジトリとの同期には、外部の Git クライアントまたはコマンドラインを使用します。詳しくは、バージョン管理マニュアルを参照してください。このビューでは、ファイルに関する次の操作を実行できます。

  • 左クリック - ファイルを選択します。⇧ Shift を押しながら操作すると選択範囲を広げられ、Ctrl/⌘ Cmd を押しながら操作すると、クリックした項目の選択と選択解除を切り替えられます。変更されたファイルを1つ選択している場合、Diff をクリックすると差分を表示できます。Revert をクリックすると、選択したすべてのファイルの変更を元に戻せます。
  • ファイルを左ダブルクリックすると、ファイルのビューが開きます。エディターは Assets ビューと同様に、そのファイルに適したエディターで開きます。
  • ファイルを右クリックするとポップアップメニューが開き、差分ビューを開く、ファイルへのすべての変更を元に戻す、ファイルシステム上でファイルを見つけるなどの操作ができます。

エディタービューの上部、または Mac のシステムバーには、FileEditViewProjectDebugHelp の6つのメニューを含むメニューバーがあります。各機能については、それぞれのマニュアルで説明します。

ステータスバー

エディターの下部には、次のような状態を表示する細い領域があります。

  • 新しい更新が利用できる場合は、クリックできる Update Available ボタンが表示されます。このマニュアルの後半にある「エディターの更新」の節を参照してください。
  • ビルド中やバンドル作成中は、ここに進行状況が表示されます。

ペインのサイズと表示

エディター内で、上記の6つのペインを区切る境界線をドラッグすると、ペインのサイズを調整できます。

エディターの View メニューの項目、または次のショートカットを使うと、ペインの表示を切り替えられます。

  • Toggle Assets PaneF6)で、Assets ペインと Changed Files ペインの表示を切り替えます。
  • Toggle Changed Files で、Changed Files ペインだけの表示を切り替えます。
  • Toggle Tools PaneF7)で、Tools ペインの表示を切り替えます。
  • Toggle Properties PaneF8)で、Outline ペインと Properties ペインの表示を切り替えます。

ペインの表示

View メニューでは、Grid、Guides、Camera などの表示に関するほかの設定の切り替えや変更、選択内容にビューを合わせる操作(Frame Selection または F キー)、既定の 2D ビューと 3D ビューの切り替え(Realign Camera または . キー)もできます。これらの多くは、ツールバーやショートカットからも操作できます。

タブ

複数のファイルを開いている場合、エディタービューの上部にファイルごとのタブが表示されます。同じペイン内のタブは、ドラッグ&ドロップでタブバー内の位置を入れ替えられます。また、次の操作もできます。

  • タブを右クリックして コンテキストメニュー を開きます。
  • CloseCtrl/⌘ Cmd + W)をクリックして、1つのタブを閉じます。
  • Close Others をクリックして、選択したタブ以外をすべて閉じます。
  • Close AllCtrl/⌘ Cmd + Shift+W)をクリックして、アクティブなペイン内のすべてのタブを閉じます。
  • ➝| Open As を選択して、既定以外のエディター、または File ▸ Preferences ▸ Code ▸ Custom Editor で設定した関連付け済みの外部ツールを使用します。詳しくは、環境設定マニュアルを参照してください。

タブ

左右に並べて編集する

2つのエディタービューを左右に並べて開けます。

  • 移動したいエディターのタブを右クリックし、Move to Other Tab Pane を選択します。

2つのペイン

タブのメニューで Swap with Other Tab Pane を使用してタブをペイン間で移動したり、Join Tab Panes を使用して1つのペインにまとめたりすることもできます。

新しいプロジェクトファイルの作成

新しいリソースファイルを作成するには、File ▸ New… を選択してからメニューでファイル形式を選択するか、コンテキストメニューを使用します。

Assets ブラウザー内の作成先を右クリックし、New… ▸ [file type] を選択します。

ファイルの作成

新しいファイルの適切な名前を Name に入力し、必要に応じて Location を変更します。ダイアログの Preview に、ファイル形式の拡張子を含む完全なファイル名が表示されます。

作成するファイルの名前

テンプレート

プロジェクトごとにカスタムテンプレートを指定できます。プロジェクトのルートディレクトリに templates という名前の新しいフォルダーを作成し、必要な拡張子を使った default.* という名前の新しいファイルを追加します。たとえば、/templates/default.gui/templates/default.script です。また、これらのファイル内で {{NAME}} トークンを使用すると、ファイル作成ウィンドウで指定したファイル名に置き換えられます。

あるファイル形式のテンプレートが用意されている場合、その形式のファイルを新しく作成するたびに、templates 内のファイルの内容で初期化されます。

テンプレート

プロジェクトへのファイルのインポート

アセット(asset)のファイル(画像、音声、モデルなど)をプロジェクトに追加するには、Assets ブラウザー内の適切な場所にドラッグ&ドロップします。プロジェクトのファイル構造内で選択した場所に、ファイルの コピー が作成されます。詳しくは、アセットのインポート方法を説明するマニュアルを参照してください。

ファイルのインポート

エディターの更新

エディターは、インターネットに接続していると自動的に更新を確認します。更新が見つかると、プロジェクト選択画面の左下、またはエディターウィンドウの右下に、クリックできる青い Update Available リンクが表示されます。

プロジェクト選択画面からの更新 エディターからの更新

Update Available リンクをクリックして、ダウンロードと更新を行います。情報を記載した確認ウィンドウが開くので、Download Update をクリックして続行します。

エディター更新のポップアップ

下部のステータスバーにダウンロードの進行状況が表示されます。

ダウンロードの進行状況

更新のダウンロードが完了すると、青いリンクが Restart to Update に変わります。クリックすると、再起動して更新後のエディターが開きます。

再起動して更新

環境設定

Preferences ウィンドウでエディターの設定を変更できます。開くには、File ▸ Preferences… をクリックするか、ショートカット Ctrl/⌘ Cmd + , を使用します。

詳しくは、環境設定マニュアルを参照してください。

環境設定

エディターのログ

エディターで問題が発生し、問題を報告(Help ▸ Report Issue)する必要がある場合は、エディター自身のログファイルを添えることをお勧めします。システムのファイルブラウザーでログの保存場所を開くには、Help ▸ Show Logs をクリックします。

詳しくは、ヘルプを得るためのマニュアルを参照してください。

ログの表示

エディターのログファイルは、次の場所にあります。

  • Windows: C:\Users\ **Your Username** \AppData\Local\Defold
  • macOS: /Users/ **Your Username** /Library/Application Support/ または ~/Library/Application Support/Defold
  • Linux: $XDG_STATE_HOME/Defold または ~/.local/state/Defold

ターミナルやコマンドプロンプトからエディターを起動した場合は、エディターの実行中にもログを確認できます。エディターを起動するには、次のコマンドを使用します。

# Linux:
$ ./path/to/Defold/Defold

# macOS:
$ > ./path/to/Defold.app/Contents/MacOS/Defold

エディターサーバー

エディターはプロジェクトを開くと、ランダムなポートで Web サーバーを起動します。このサーバーを使用して、ほかのアプリケーションからエディターを操作できます。ポートは .internal/editor.port ファイルに書き込まれます。

サーバーは http://localhost:$(cat .internal/editor.port)/openapi.json で OpenAPI 仕様を提供します。これは、エージェントを活用したワークフローを始める際の最小限の出発点として役立ちます。

また、エディターの実行ファイルには、起動時にポートを指定できるコマンドラインオプション --port(または -p)があります。たとえば次のように指定します::

# Windows
.\path\to\Defold\Defold.exe --port 8181

# Linux:
./path/to/Defold/Defold --port 8181

# macOS:
./path/to/Defold/Defold.app/Contents/MacOS/Defold --port 8181

エディターのインストールメタデータ

エディターは起動時に、ランチャーとインストール先のパスに関する情報を、定められた場所に書き込みます。サードパーティーの IDE 連携機能やほかのツールは、この情報を使ってインストール済みの Defold エディターを見つけられます。

OS 場所
macOS ~/Library/Application Support/Defold/installations.json
Linux ${XDG_STATE_HOME:-~/.local/state}/Defold/installations.json
Windows %LOCALAPPDATA%\Defold\installations.json

ファイルには、既知のインストールごとに1つのオブジェクトを含む JSON 配列が格納されます。

[
  {
    "launcherPath": "/Applications/Defold.app/Contents/MacOS/Defold",
    "installPath": "/Applications/Defold.app",
    "lastLaunchedAt": "2026-07-06T12:34:56.789Z"
  }
]

エディターのスタイル設定

カスタムのスタイル設定で、エディターの外観を変更できます。詳しくは、エディターのスタイル設定マニュアルを参照してください。

よくある質問

Q: エディターのシステム要件は何ですか?

A: エディターはシステムで利用可能なメモリの最大75%を使用します。RAM が 4 GB のコンピューターでも、小規模な Defold プロジェクトには十分なはずです。中規模または大規模なプロジェクトでは、6 GB 以上の RAM を推奨します。

Q: Defold のベータ版は自動更新されますか?

A: はい。Defold のベータ版エディターは、安定版と同様に起動時に更新を確認します。

Q: エディターの起動時に java.awt.AWTError: Assistive Technology not found というエラーが表示されるのはなぜですか?

A: このエラーは、NVDA スクリーンリーダーなどの Java の支援技術の問題に関連しています。おそらくホームフォルダーに .accessibility.properties ファイルがあります。そのファイルを削除して、エディターを再度起動してみてください。(注: 支援技術を使用していて、このファイルが必要な場合は、代替の解決策を相談するために info@defold.se までご連絡ください)。

Defold フォーラムのこちらのトピックで議論されています。

Q: エディターの起動時に sun.security.validator.ValidatorException: PKIX path building failed というエラーが表示されるのはなぜですか?

A: この例外は、エディターが https 接続を試みたときに、サーバーから提供された証明書チェーンを検証できない場合に発生します。

このエラーの詳細は、こちらのリンクを参照してください。

Q: 特定の操作を行うと java.lang.OutOfMemoryError: Java heap space が発生するのはなぜですか?

A: Defold エディターは Java で作られており、Java の既定のメモリ設定では不十分な場合があります。その場合は、エディターの設定ファイルを編集して、より多くのメモリを割り当てるよう手動で設定できます。config という名前の設定ファイルは、macOS では Defold.app/Contents/Resources/ フォルダーにあります。Windows では実行ファイル Defold.exe と同じ場所、Linux では実行ファイル Defold と同じ場所にあります。config ファイルを開き、vmargs で始まる行に -Xmx6gb を追加します。-Xmx6gb を追加すると、ヒープサイズの上限が6ギガバイトに設定されます(既定値は通常 4Gb です)。次のようになります。

vmargs = -Xmx6gb,-Dfile.encoding=UTF-8,-Djna.nosys=true,-Ddefold.launcherpath=${bootstrap.launcherpath},-Ddefold.resourcespath=${bootstrap.resourcespath},-Ddefold.version=${build.version},-Ddefold.editor.sha1=${build.editor_sha1},-Ddefold.engine.sha1=${build.engine_sha1},-Ddefold.buildtime=${build.time},-Ddefold.channel=${build.channel},-Ddefold.archive.domain=${build.archive_domain},-Djava.net.preferIPv4Stack=true,-Dsun.net.client.defaultConnectTimeout=30000,-Dsun.net.client.defaultReadTimeout=30000,-Djogl.texture.notexrect=true,-Dglass.accessible.force=false,--illegal-access=warn,--add-opens=java.base/java.lang=ALL-UNNAMED,--add-opens=java.desktop/sun.awt=ALL-UNNAMED,--add-opens=java.desktop/sun.java2d.opengl=ALL-UNNAMED,--add-opens=java.xml/com.sun.org.apache.xerces.internal.jaxp=ALL-UNNAMED