Manuals
Manuals




This translation is community contributed and may not be up to date. We only maintain the English version of the documentation. Read this manual in English

L’editor di scena di Defold

L’editor di scena (Scene Editor) è l’editor visivo utilizzato per creare e modificare scene come collezioni, oggetti di gioco e altri asset visivi.

Per impostazione predefinita, molte scene visive si aprono con una vista ortografica 2D. Per lavorare in 3D puoi passare a un layout orientato al 3D, attivare un piano della griglia 3D e utilizzare una telecamera prospettica.

Aprire l’editor di scena

Apri l’editor di scena facendo doppio clic su una risorsa visiva nel pannello Assets, ad esempio:

  • Struttura della scena — collezioni (.collection), oggetti di gioco (.go)
  • Asset 2D — atlas (.atlas), mappe di tile (.tilemap), sprite (.sprite), sorgenti di tile (.tilesource)
  • Asset 3D — modelli (.model, .glb, .gltf)
  • UI — scene GUI (.gui)
  • Effetti — effetti particellari (.particlefx)
  • E altri ancora

Navigazione nella vista della scena (controlli della telecamera)

La telecamera dell’editor di scena può essere controllata con il mouse e la tastiera. I controlli disponibili dipendono dall’uso della navigazione standard della telecamera o della modalità telecamera libera (Free Camera Mode).

Navigazione standard (tutti gli editor visivi)

Questi controlli sono disponibili negli editor visivi:

  • Traslazione
    • Alt/⌥ Option + Left Mouse Button
  • Zoom
    • Mouse Wheel, oppure
    • Ctrl/^ Control + Alt/⌥ Option + Left Mouse Button
  • Rotazione/orbita (3D) attorno alla selezione
    • Ctrl/^ Control + Left Mouse Button

Puoi anche utilizzare Frame Selection (F) per inquadrare la selezione corrente con la telecamera.

Orientamento della scena in 2D e 3D {#2d-and-3d-scene-orientation}

La vista della scena può essere utilizzata sia per lavorare in 2D sia in 3D:

  • In 2D, in genere lavori con una vista ortografica e una griglia orientata al 2D.
  • In 3D, in genere:
    • Riallinei la vista a un orientamento 3D,
    • Utilizzi una telecamera prospettica,
    • Scegli un piano della griglia adatto (spesso Y per il “terreno”).

Puoi accedere a queste funzioni tramite la barra degli strumenti e il menu View.

Editor di scena in 3D

Panoramica della barra degli strumenti

In alto a destra nella vista della scena è presente una barra con gli strumenti e le opzioni di visualizzazione più comuni (da sinistra a destra):

  • Move tool (W)
  • Rotate tool (E)
  • Scale tool (R)
  • Grid Settings ()
  • Align/Realign Camera 2D/3D (2D) — alterna tra l’orientamento 2D e 3D (scorciatoia .)
  • Camera Perspective/Orthographic
  • Visibility Filters (👁)

Barra degli strumenti

Selezionare e manipolare gli oggetti

Selezionare gli oggetti

Fai clic con il pulsante sinistro del mouse sugli oggetti nella finestra principale per selezionarli. Il rettangolo (o parallelepipedo) che circonda l’oggetto nella vista dell’editor viene evidenziato in ciano per indicare quale elemento è selezionato. L’oggetto selezionato viene evidenziato anche nella vista Outline, come nell’immagine sopra.

Puoi selezionare gli oggetti anche nei seguenti modi:

  • Fai clic con il pulsante sinistro del mouse e trascina per selezionare tutti gli oggetti all’interno dell’area di selezione.
  • Fai clic con il pulsante sinistro del mouse sugli oggetti nella vista Outline: tenendo premuto ⇧ Shift puoi estendere la selezione, mentre tenendo premuto Ctrl/⌘ Cmd puoi selezionare o deselezionare l’oggetto su cui fai clic.

Strumento di spostamento

Strumento di spostamento

Per spostare gli oggetti, usa lo strumento Move Tool. Puoi trovarlo nella barra degli strumenti in alto a destra nell’editor di scena oppure attivarlo premendo il tasto W.

Spostamento di un oggettoSpostamento di un oggetto in 3D

Il gizmo cambia e mostra una serie di manipolatori, quadrati e frecce (il manipolatore selezionato diventa arancione), che puoi trascinare per spostare l’oggetto:

  • una maniglia quadrata centrale ciano per spostare l’oggetto solo nello spazio dello schermo,
  • 3 frecce rosse, verdi e blu lungo ciascun asse per spostare l’oggetto solo lungo l’asse X, Y o Z corrispondente.
  • 3 maniglie quadrate rosse, verdi e blu (con contorno e riempimento trasparente) per spostare l’oggetto solo sul piano corrispondente, ad esempio il piano X-Y (blu) e i piani X-Z (verde) e Y-Z (rosso), visibili ruotando la telecamera in 3D.

Strumento di rotazione

Strumento di rotazione

Per ruotare gli oggetti, usa lo strumento Rotate Tool selezionandolo nella barra degli strumenti oppure premendo il tasto E.

Rotazione di un oggettoRotazione di un oggetto in 3D

Questo strumento è composto da quattro manipolatori circolari (il manipolatore selezionato diventa arancione) che puoi trascinare per ruotare l’oggetto:

  • un manipolatore ciano (il cerchio esterno, più grande) che ruota l’oggetto nello spazio dello schermo
  • 3 manipolatori circolari più piccoli, rossi, verdi e blu, che consentono di ruotare separatamente attorno a ciascuno degli assi X, Y e Z. Nella vista ortografica 2D, due di essi sono perpendicolari agli assi X e Y, quindi i cerchi appaiono come due linee che attraversano l’oggetto.

Strumento di ridimensionamento

Strumento di ridimensionamento

Per ridimensionare gli oggetti, usa lo strumento Scale Tool selezionandolo nella barra degli strumenti oppure premendo il tasto R.

Ridimensionamento di un oggettoRidimensionamento di un oggetto in 3D

Questo strumento è composto da una serie di manipolatori quadrati e cubici (il manipolatore selezionato diventa arancione) che puoi trascinare per ridimensionare l’oggetto:

  • un cubo ciano al centro ridimensiona l’oggetto uniformemente su tutti gli assi (compreso Z).
  • 3 manipolatori cubici rossi, blu e verdi ridimensionano l’oggetto separatamente lungo ciascuno degli assi X, Y e Z.
  • 3 manipolatori quadrati rossi, verdi e blu (con contorno e riempimento trasparente) ridimensionano l’oggetto separatamente sui piani X-Y, X-Z o Y-Z.

Filtri di visibilità

Fai clic sull’icona a forma di occhio della visibilità (👁) nella barra degli strumenti per attivare o disattivare la visualizzazione dei vari tipi di componenti, dei riquadri di delimitazione e delle linee guida (Component Guides oppure la scorciatoia Ctrl + H (Win/Linux) o ^ Ctrl + ⌘ Cmd + H(Mac)).

Filtri di visibilità

Impostazioni della griglia

Puoi personalizzare la griglia in base al tuo flusso di lavoro (particolarmente utile in 3D). Fai clic sul pulsante Grid Settings () per aprire il popup delle impostazioni della griglia.

Impostazioni della griglia

Le impostazioni comprendono:

  • Grid size (X/Y/Z) Imposta la distanza tra le linee della griglia lungo ciascun asse. Utilizza valori più piccoli per posizionare con precisione gli oggetti piccoli, oppure valori più grandi per una visione d’insieme più ampia.
  • Active plane (X/Y/Z) Seleziona il piano su cui viene disegnata la griglia. Quando lavori in 2D, in genere è Z (il piano X-Y predefinito). In 3D, si usa spesso Y per rappresentare un terreno o un pavimento.
  • Grid color Imposta il colore delle linee della griglia. Utile per ottenere contrasto con i diversi sfondi della scena.
  • Grid opacity Controlla la trasparenza delle linee della griglia. Valori più bassi rendono la griglia meno invadente, mantenendola comunque come riferimento.
  • Un pulsante Reset to Defaults Ripristina tutte le impostazioni della griglia ai valori originali.

Tipo di telecamera: prospettica e ortografica

L’editor di scena supporta entrambi i tipi:

  • Telecamera ortografica (comune quando si lavora in 2D)
  • Telecamera prospettica (comune quando si lavora in 3D)

Utilizza il pulsante della telecamera nella barra degli strumenti per passare da un tipo all’altro. Nelle scene 3D, la navigazione prospettica risulta in genere più naturale.

Modalità telecamera libera

Per navigare rapidamente in 3D, l’editor di scena offre la modalità telecamera libera, una telecamera in prima persona, in “stile FPS”.

Attivare la modalità telecamera libera

  • Tieni premuto Right Mouse Button — la modalità telecamera libera rimane attiva finché tieni premuto il pulsante
  • Shift + ` (accento grave) — attiva la modalità telecamera libera, mantenendola attiva anche dopo il rilascio

In alcuni layout di tastiera (ad esempio quello svedese), il tasto dell’accento grave è un tasto morto e potrebbe non attivare la scorciatoia come previsto. Puoi riassegnare questa scorciatoia in File ▸ Preferences ▸ Keys e inserire una combinazione per Scene -> Free Camera -> Activate

Quando la modalità telecamera libera è attiva, la vista della scena viene evidenziata da una linea lungo i bordi.

Uscire dalla modalità telecamera libera

  • Rilascia Right Mouse Button (se l’hai attivata tenendolo premuto), oppure
  • Premi Left Mouse Button, Right Mouse Button (premi e rilascia) oppure Esc se la modalità telecamera libera è stata attivata in modo persistente.

Guardarsi intorno (visuale con il mouse)

Quando la modalità telecamera libera è attiva, questi controlli gestiscono il movimento della telecamera (anziché gli strumenti dell’editor):

  • Muovi il mouse per controllare l’imbardata (sinistra/destra) e il beccheggio (alto/basso)
  • Il beccheggio è limitato per evitare che la telecamera si capovolga

Puoi anche invertire l’asse Y (vedi Impostazioni della telecamera libera di seguito).

Spostarsi

Quando la modalità telecamera libera è attiva:

  • W — avanti
  • S — indietro
  • A — a sinistra
  • D — a destra
  • E — in alto
  • Q — in basso

Tutti i tasti di movimento possono essere riassegnati in File ▸ Preferences ▸ Keys. Cerca poi Scene -> Free Camera

Modificatori di velocità:

  • Tieni premuto Shift — muoviti più velocemente
  • Tieni premuto Alt/⌥ Option — muoviti più lentamente e con maggiore precisione

Modalità camminata (facoltativa)

La modalità telecamera libera supporta la modalità camminata (Walking Mode).

Quando è attiva:

  • Il movimento verso l’alto e il basso è vincolato per riprodurre meglio una camminata in prima persona su un piano del terreno.
  • È utile quando esplori un livello e vuoi mantenere un movimento coerente “a terra”.

Popup delle impostazioni della telecamera

Il pulsante della telecamera prospettica nella barra degli strumenti dispone di un popup con le preferenze relative alla telecamera.

Impostazioni della telecamera prospettica

Il popup contiene:

  • Move Speed Regola la velocità di movimento della telecamera libera.

  • Look Sensitivity Regola la velocità con cui la telecamera ruota in risposta al movimento del mouse.

  • Invert Y Inverte il movimento verticale della visuale con il mouse.

  • Walking Mode Vincola il movimento per una navigazione simile a una camminata sul terreno.

  • Reset to Defaults Ripristina le impostazioni predefinite della telecamera.