Manuals
Manuals




This translation is community contributed and may not be up to date. We only maintain the English version of the documentation. Read this manual in English

O editor de cena do Defold

O Scene Editor é o editor visual usado para construir e editar cenas, como coleções, objetos de jogo e outros assets visuais.

A visualização inicial da câmera depende do recurso. Recursos 3D como modelos e cenas glTF usam perspectiva por padrão, enquanto recursos 2D como sprites, tilemaps e cenas GUI usam projeção ortográfica. Você pode alterar a orientação, a projeção e a grade da câmera pela barra de ferramentas da cena.

Abrindo o Scene Editor

Abra o Scene Editor dando duplo clique em um recurso visual no painel Assets, como:

  • Estrutura de cena - coleções (.collection), objetos de jogo (.go)
  • Assets 2D - atlas (.atlas), tilemaps (.tilemap), sprites (.sprite), tile sources (.tilesource)
  • Assets 3D - modelos (.model, .glb, .gltf)
  • UI - cenas GUI (.gui)
  • Efeitos - efeitos de partículas (.particlefx)
  • E outros

Visualizações de cena salvas

O editor salva o estado da câmera de cada recurso de cena quando sua aba é fechada ou quando o editor é encerrado. Reabrir o mesmo recurso restaura sua visualização, de modo que coleções ou modelos diferentes podem manter posições, orientações e projeções de câmera diferentes.

Os filtros de visibilidade também são salvos por cena. Ocultar modelos ou guias de componentes em uma cena não exige usar os mesmos filtros em outra. Essas configurações afetam a visualização do editor e não alteram a câmera do jogo nem a visibilidade em tempo de execução.

Para recursos sem estado de câmera salvo, modelos, malhas e recursos glTF iniciam em perspectiva. Objetos de colisão escolhem sua visualização conforme a configuração de física 2D/3D do projeto; coleções e objetos de jogo escolhem a visualização inicial com base na geometria da cena.

A câmera do Scene Editor pode ser controlada com mouse e teclado. Os controles disponíveis dependem de você estar usando a navegação padrão da câmera ou o Free Camera Mode.

Estes controles estão disponíveis em editores visuais:

  • Pan
    • Alt/⌥ Option + Left Mouse Button
  • Zoom
    • Mouse Wheel, ou
    • Ctrl/^ Control + Alt/⌥ Option + Left Mouse Button
  • Rotacionar/orbitar (3D) ao redor da seleção
    • Ctrl/^ Control + Left Mouse Button

Você também pode usar Frame Selection (F) para focar a câmera na seleção atual.

Orientação de cena 2D e 3D {#2d-and-3d-scene-orientation}

A visualização de cena pode ser usada em fluxos de trabalho 2D e 3D:

  • Em 2D, você normalmente trabalha em uma visualização ortográfica com uma grade orientada a 2D.
  • Em 3D, você normalmente:
    • Realinha a visualização para uma orientação 3D,
    • Usa uma câmera perspectiva,
    • Escolhe um plano de grade apropriado (frequentemente Y para “chão”).

Você pode acessar essas funções pela barra de ferramentas e pelo menu View.

Scene Editor 3D

Visão geral da barra de ferramentas

No canto superior direito da visualização de cena há uma barra de ferramentas com ferramentas e opções de visualização usadas com frequência (da esquerda para a direita):

  • Move tool (W)
  • Rotate tool (E)
  • Scale tool (R)
  • Grid Settings (▦)
  • Align/Realign Camera 2D/3D (2D) - alterna entre orientação 2D e 3D (atalho .)
  • Camera Perspective/Orthographic
  • Visibility Filters (👁)

Toolbar

Selecionando e manipulando objetos

Selecionando objetos

Use Left Mouse Click em objetos na janela principal para selecioná-los. O retângulo (ou cuboide) ao redor do objeto na visualização do editor será destacado em ciano para indicar qual item está selecionado. O objeto selecionado também é destacado na visualização Outline, como na imagem acima.

Você também pode selecionar objetos assim:

  • Left Mouse Click e Drag para selecionar todos os objetos dentro da região de seleção.
  • Left Mouse Click em objetos no Outline; mantendo ⇧ Shift pressionado, você pode expandir a seleção, ou mantendo Ctrl/⌘ Cmd, pode selecionar/desselecionar o item clicado.

Move tool

Move tool

Para mover objetos, use a Move Tool. Você pode encontrá-la na barra de ferramentas no canto superior direito do editor de cena ou pressionar a tecla W.

Move objectMove object 3D

O gizmo muda e mostra um conjunto de manipuladores - quadrados e setas (o manipulador selecionado ficará laranja) que você pode Drag para mover:

  • uma alça quadrada central ciano para mover o objeto apenas no espaço da tela,
  • 3 setas vermelha, verde e azul ao longo de cada eixo para mover o objeto apenas no eixo X, Y ou Z indicado.
  • 3 alças quadradas vermelha, verde e azul (com contorno e preenchimento transparente) para mover o objeto apenas no plano indicado, por exemplo X-Y (azul) e (visível ao rotacionar a câmera em 3D) os planos X-Z (verde) e Y-Z (vermelho).

Rotate tool

Rotate tool

Para rotacionar objetos, use a Rotate Tool selecionando-a na barra de ferramentas ou pressionando a tecla E.

Rotate objectRotate object 3D

Essa ferramenta consiste em quatro manipuladores circulares (o manipulador selecionado ficará laranja) que você pode Drag para rotacionar:

  • um manipulador ciano (círculo externo, maior) que rotaciona o objeto no espaço da tela
  • 3 manipuladores circulares menores, vermelho, verde e azul, que permitem rotação em torno dos eixos X, Y e Z separadamente. Na visualização 2D ortográfica, dois deles ficam perpendiculares aos eixos X e Y, então os círculos aparecem apenas como duas linhas cruzando o objeto.

Scale tool

Scale tool

Para escalar objetos, use a Scale Tool selecionando-a na barra de ferramentas ou pressionando a tecla R.

Scale objectScale object 3D

Essa ferramenta consiste em um conjunto de manipuladores quadrados/cúbicos (o manipulador selecionado ficará laranja) que você pode Drag para escalar:

  • um cubo ciano no centro escala o objeto uniformemente em todos os eixos (incluindo Z).
  • 3 manipuladores cúbicos vermelho, azul e verde escalam o objeto ao longo dos eixos X, Y e Z separadamente.
  • 3 manipuladores quadrados vermelho, verde e azul (com contorno e preenchimento transparente) escalam o objeto nos planos X-Y, X-Z ou Y-Z separadamente.

Filtros de visibilidade

Clique no Visibility Eye Icon (👁) na barra de ferramentas para alternar a visibilidade de vários tipos de componentes, além de caixas delimitadoras e linhas-guia (Component Guides ou o atalho Ctrl + H (Win/Linux) ou ^ Ctrl + ⌘ Cmd + H(Mac)).

Visibility filters

Configurações da grade

A grade pode ser personalizada para se ajustar ao seu fluxo de trabalho (especialmente útil em 3D). Clique no botão Grid Settings (▦) para abrir o popup de configurações da grade.

O editor mantém configurações de grade separadas para visualizações 2D e 3D. Defina tamanho, plano e aparência enquanto o modo desejado estiver ativo; alternar entre os modos restaura as configurações de grade de cada um. Reset to Defaults redefine as configurações do modo ativo.

Grid Settings

As configurações incluem:

  • Grid size (X/Y/Z) Define o espaçamento entre as linhas da grade ao longo de cada eixo. Use valores menores para posicionamento preciso de objetos pequenos, ou valores maiores para uma visão geral mais ampla.
  • Active plane (X/Y/Z) Seleciona em qual plano a grade é desenhada. Em fluxos de trabalho 2D, normalmente é Z (o plano X-Y padrão). Em fluxos 3D, Y é comum para representar um plano de chão/piso.
  • Grid color Define a cor das linhas da grade. Útil para contraste contra diferentes fundos de cena.
  • Grid opacity Controla a transparência das linhas da grade. Valores menores tornam a grade menos intrusiva, mantendo-a como referência.
  • Um botão Reset to Defaults Restaura todas as configurações da grade para seus valores originais.

Tipo de câmera: Perspective vs Orthographic

O Scene Editor suporta ambos:

  • Câmera Orthographic (comum em fluxos de trabalho 2D)
  • Câmera Perspective (comum em fluxos de trabalho 3D)

Use o alternador de câmera na barra de ferramentas para trocar. Em cenas 3D, a navegação em perspectiva normalmente parece mais natural.

Free Camera Mode

Para navegação 3D rápida, o Scene Editor fornece o Free Camera Mode, uma câmera em primeira pessoa / estilo “FPS”.

Ativando o Free Camera Mode

  • Segure Right Mouse Button - o Free Camera Mode fica ativo enquanto o botão estiver pressionado
  • Shift + ` (crase) - alterna o Free Camera Mode para ligado, mantendo-o ativo após soltar

Em alguns layouts de teclado (por exemplo, sueco), a tecla de crase é uma tecla morta e pode não acionar o atalho como esperado. Você pode reatribuir esse atalho em File ▸ Preferences ▸ Keys e informar um atalho para Scene -> Free Camera -> Activate

Quando o Free Camera Mode está ativo, a Scene View é destacada com uma linha ao redor das bordas.

Saindo do Free Camera Mode

  • Solte Right Mouse Button (quando ativado ao segurar), ou
  • Left Mouse Button, Right Mouse Button (pressionar e soltar), ou pressione Esc quando o Free Camera Mode tiver sido ativado como alternância.

Olhando ao redor (mouse look)

Enquanto o Free Camera Mode está ativo, estas teclas controlam o movimento da câmera (em vez das ferramentas do editor):

  • Mova o mouse para controlar yaw (esquerda/direita) e pitch (cima/baixo)
  • O pitch é limitado para evitar que a câmera vire de cabeça para baixo

Você também pode opcionalmente inverter o eixo Y (veja Free camera settings abaixo).

Movimento

Enquanto o Free Camera Mode está ativo:

  • W - para frente
  • S - para trás
  • A - para a esquerda
  • D - para a direita
  • E - para cima
  • Q - para baixo

Todas as teclas de movimento podem ser reatribuídas em File ▸ Preferences ▸ Keys. Depois procure por Scene -> Free Camera

Modificadores de velocidade:

  • Segure Shift - mover mais rápido
  • Segure Alt/⌥ Option - mover mais devagar / com mais precisão

Walking mode (opcional)

O Free Camera Mode suporta Walking Mode.

Quando ativado:

  • O movimento para cima/baixo é restringido para se comportar mais como caminhada em primeira pessoa presa a um plano de chão.
  • Isso é útil ao explorar um nível e querer um movimento “no chão” consistente.

O botão da câmera perspectiva na barra de ferramentas tem um popup de configurações relacionadas à câmera.

Perspective Camera Settings

O popup contém:

  • Move Speed Ajusta a velocidade de movimento da câmera livre.

  • Look Sensitivity Ajusta a rapidez com que a câmera rotaciona em resposta ao movimento do mouse.

  • Invert Y Inverte a visão vertical pelo mouse.

  • Walking Mode Restringe o movimento para uma navegação semelhante a caminhar no chão.

  • Reset to Defaults Restaura as configurações padrão da câmera.