This translation is community contributed and may not be up to date. We only maintain the English version of the documentation. Read this manual in English
Редактор сцены — это визуальный редактор для создания и редактирования сцен, таких как коллекции, игровые объекты и другие визуальные ассеты.
Исходный вид камеры зависит от ресурса. 3D-ресурсы, такие как модели и сцены glTF, по умолчанию используют перспективную проекцию, а 2D-ресурсы, такие как спрайты, тайловые карты и GUI-сцены, — ортографическую. Ориентацию камеры, проекцию и сетку можно изменить через панель инструментов сцены.
Чтобы открыть редактор сцены, дважды щёлкните по визуальному ресурсу в панели Assets, например:
.collection), игровые объекты (.go).atlas), тайлмапы (.tilemap), спрайты (.sprite), источники тайлов (.tilesource).model, .glb, .gltf).gui).particlefx)Редактор запоминает состояние камеры для каждого ресурса сцены при закрытии его вкладки или выходе из редактора. При повторном открытии того же ресурса его вид восстанавливается, поэтому разные коллекции или модели могут сохранять разные положения, ориентации и проекции камеры.
Фильтры видимости также запоминаются отдельно для каждой сцены. Если скрыть модели или направляющие компонентов в одной сцене, в другой можно использовать другие фильтры. Это настройки вида в редакторе; они не изменяют камеру игры или видимость во время выполнения.
Для ресурсов без сохранённого состояния камеры модели, сетки и ресурсы glTF открываются в перспективной проекции. Вид объектов столкновения выбирается на основе настройки 2D/3D-физики проекта; для коллекций и игровых объектов исходный вид определяется по геометрии сцены.
Камерой редактора сцены можно управлять мышью и клавиатурой. Доступные действия зависят от того, используете ли вы стандартную навигацию камеры или режим свободной камеры.
Эти действия доступны в визуальных редакторах:
Также можно использовать Frame Selection (F), чтобы сфокусировать камеру на текущем выделении.
Вид сцены можно использовать как в 2D-, так и в 3D-процессах работы:
Эти функции доступны через панель инструментов и меню View.

В правом верхнем углу вида сцены находится панель инструментов с часто используемыми инструментами и настройками вида (слева направо):
▦)2D) — переключает 2D- и 3D-ориентацию (клавиша .)👁)
Щёлкните левой кнопкой мыши по объекту в главном окне, чтобы выделить его. Прямоугольник (или кубоид) вокруг объекта в виде редактора подсветится бирюзовым цветом, показывая, какой элемент выбран. Выделенный объект также подсвечивается в панели Outline, как на изображении выше.
Можно также выделять объекты так:
Outline; удерживайте ⇧ Shift, чтобы расширить выделение, или Ctrl/⌘ Cmd, чтобы выделить или снять выделение с нажатого элемента.![]()
Чтобы перемещать объекты, используйте Move Tool. Его можно выбрать на панели инструментов в правом верхнем углу редактора сцены или включить клавишей W.


Гизмо изменится и покажет набор манипуляторов — квадраты и стрелки (выбранный манипулятор становится оранжевым), которые можно перетаскивать для перемещения:
![]()
Чтобы вращать объекты, используйте Rotate Tool, выбрав его на панели инструментов или нажав E.


Этот инструмент состоит из четырёх круговых манипуляторов (выбранный манипулятор становится оранжевым), которые можно перетаскивать для вращения:
![]()
Чтобы масштабировать объекты, используйте Scale Tool, выбрав его на панели инструментов или нажав R.


Этот инструмент состоит из набора квадратных/кубических манипуляторов (выбранный манипулятор становится оранжевым), которые можно перетаскивать для масштабирования:
Нажмите на значок глаза (👁) на панели инструментов, чтобы переключать видимость различных типов компонентов, а также рамок и направляющих линий (Component Guides, сочетание клавиш Ctrl + H в Windows/Linux или ^ Ctrl + ⌘ Cmd + H на Mac).

Сетку можно настроить под свой процесс работы (это особенно полезно в 3D). Нажмите кнопку Grid Settings (▦), чтобы открыть всплывающее окно настроек сетки.
Редактор хранит отдельные настройки сетки для 2D- и 3D-видов. Задавайте размер, плоскость и внешний вид, пока нужный режим активен; при переключении восстанавливаются настройки сетки соответствующего режима. Reset to Defaults сбрасывает настройки активного режима.

Доступные настройки:
Редактор сцены поддерживает оба варианта:
Используйте переключатель камеры на панели инструментов, чтобы сменить тип камеры. В 3D-сценах навигация с перспективной камерой обычно ощущается естественнее.
Для быстрой 3D-навигации редактор сцены предоставляет режим свободной камеры — камеру от первого лица в стиле FPS.
На некоторых раскладках клавиатуры (например, шведской) клавиша обратного апострофа является “мёртвой” клавишей и может не сработать как ожидается. Вы можете переназначить это сочетание в File ▸ Preferences ▸ Keys и задать сочетание для Scene -> Free Camera -> Activate
Когда режим свободной камеры активен, вид сцены подсвечивается линией по краям.
Пока режим свободной камеры активен, эти действия управляют движением камеры вместо инструментов редактора:
Также можно включить инверсию оси Y (см. раздел Всплывающее окно настроек камеры ниже).
Пока режим свободной камеры активен:
Все клавиши перемещения можно переназначить в File ▸ Preferences ▸ Keys. Затем выполните поиск по Scene -> Free Camera
Модификаторы скорости:
Режим свободной камеры поддерживает режим ходьбы.
Когда он включён:
У кнопки перспективной камеры на панели инструментов есть всплывающее окно с настройками камеры.

Окно содержит:
Move Speed Настраивает скорость перемещения свободной камеры.
Look Sensitivity Настраивает скорость поворота камеры в ответ на движение мыши.
Invert Y Инвертирует вертикальное движение обзора мышью.
Walking Mode Ограничивает движение для навигации, похожей на движение по поверхности.
Reset to Defaults Восстанавливает настройки камеры по умолчанию.